Forums

 
ForumForumPlug-in and Pla...Plug-in and Pla...Outlook Plug-inOutlook Plug-inSessionID error in Outlook 2007 VistaSessionID error in Outlook 2007 Vista
Previous Previous
 
Next Next
New Post
 10/12/2007 6:03 AM
 
 Modified By Arnaud VATEL  on 10/12/2007 7:34:07 AM

Hi,

I'm trying to synchronise my Outlook 2007 (running on Vista x64) with SplendidCRM Version 4.2.0 Build 1.4.2774.40222.
The plugin version is 1.4.2727.3709.

I have successfully installed VS2005SE for Office 2003/2007 and PIA for Office 2007.
The toolbar appears as expected and I could successfully perform a connection test between Outlook and SplendidCRM. I can also do a search when I try to assign a mail to an accoutn. But whenever I try to synchronise contacts or calendar or to assign an account to an e-mail I get the following error :

'System.Exception: The session ID is invalid' and a reference to line 529 and 2131 in soap.asmx.cs

I saw on another post that there a beta that could fix the problem (http://download.splendidcrm.com/SplendidCRM_1.4.2745.38512_Beta_Upgrade.msi) but the link is broken.

Has the problem been fixed now ?

Thanks in advance. Regards,
Arno

PS : I have exactly the same error on another machine under XP with Outlook 2003.
I'm using basic auth.

PPS : I finally succeeded in synchronising once. I have to restart the server each time I want to synchronise again !

New Post
 10/12/2007 8:01 AM
 

Please try more recent builds of the plug-in and the SplendidCRM app.  We are still testing these builds and we would appreciate your feedback.

http://s3.amazonaws.com/SplendidCRM/SplendidCRM_Plug-in_for_Outlook_1.4.2824.5474.msi

http://s3.amazonaws.com/SplendidCRM/SplendidCRM_1.4.2819.7340_Beta_Upgrade.msi

New Post
 10/12/2007 9:35 AM
 

Hi,

after upgrading SplendidCRM, I get the following error on line 50 of \_controls\TabMenu.ascx :

CS0117: 'SplendidCRM.L10N' does not contain any definition for 'IsLanguageRTL'

New Post
 10/12/2007 10:06 AM
 

That error suggest that the DLL did not get updated.  It may have been lock by IIS.  Please stop IIS and reinstall the update.

 

New Post
 10/12/2007 10:15 AM
 
 Modified By Arnaud VATEL  on 10/12/2007 10:20:15 AM

I still get the error after stopping IIS and repairing the install.
But you're right in your assumption that dll hasn't been updated : SplendidCRM.dll is still 1.4.2774.40222.

Update : I got it working by deleting the dll bedore repairing. It forced the install to reinstall the good dll.

Previous Previous
 
Next Next
ForumForumPlug-in and Pla...Plug-in and Pla...Outlook Plug-inOutlook Plug-inSessionID error in Outlook 2007 VistaSessionID error in Outlook 2007 Vista