Forums

 
ForumForumMainstream Foru...Mainstream Foru...General Discuss...General Discuss...Search by checkboxes not working - BUG?Search by checkboxes not working - BUG?
Previous Previous
 
Next Next
New Post
 3/30/2012 10:34 AM
 

Hi,

I have multiple checkboxes list field, business type: Goverment, Education, Other etc.

the field type is text (varchar 255), proper list has been created. I can edit and save multiple values, but when I search (by checking boxes), IT SHOWS ALL RECORDS. My selection criteria are ignored. Looks like some kind of bug. Please advise

Also how can I see my threads in this forum?? I clicked my user profile and links are not there...


New Post
 3/30/2012 11:59 AM
 

It would be helpful if you could enable the show_sql flag and provide the SQL resulting from the search. I suspect that the problem is that the search code is using a value set search instead of a contains search. Since a checkbox list is stored as XML, its stored value will only be exactly the same as the search value if the list contains one entry.

As for looking for threads in this forum, there should be a Manage link hovering over the forum name.  In there is a My Threads link.

 

New Post
 3/31/2012 7:55 AM
 

How do I enable Show_SQL flag? So is it a bug? I did not do anything custom, just simply enabled multiple checkboxes list, should not this work out of the box? How to enable "contains" search? I am also not sure I understand your reply. My list contains multiple entries.

I do not see any "manage" link, have looked everywhere already.

How can I get replies by email to this thread?

New Post
 3/31/2012 8:28 AM
 
 Modified By GoogWiz.com  on 3/31/2012 9:08:35 AM

Ok, I was able to enable the Show SQl flag. Seems like Business Type checkbox list values are COMPLETLY ignored on the search box (even I checked 3 diffrent values):

select NAME
     , ASSIGNED_USER_ID
     , ID
     , STATUS
     , ACCOUNT_NAME
     , EMAIL1
     , PHONE_WORK
     , ASSIGNED_TO_NAME
     , TEAM_NAME
     , PRIMARY_ADDRESS_STREET
     , PRIMARY_ADDRESS_CITY
     , PRIMARY_ADDRESS_STATE
     , PRIMARY_ADDRESS_POSTALCODE
     , PRIMARY_ADDRESS_COUNTRY
     , PHONE_MOBILE
     , PHONE_HOME
  from vwLEADS_List
 where 1 = 1
   and (          FIRST_NAME like N'%A.N.S%' escape '\'
       )
 order by NAME asc;
 


New Post
 3/31/2012 8:48 AM
 
 Modified By GoogWiz.com  on 3/31/2012 9:06:55 AM

I have also tried and converted checkbox list to a dropdown and that does not display proper record. Nothing is displayed when TT is selected... 

The record has the values: Business Type: RT: Retail & Trading, TT: Travel & 

Seems both checkbox list and dropdown are not working correctly when placed on serach form. Here is SQL with dropdown (instead of checkbox list):

select NAME
     , ASSIGNED_USER_ID
     , ID
     , STATUS
     , ACCOUNT_NAME
     , EMAIL1
     , PHONE_WORK
     , ASSIGNED_TO_NAME
     , TEAM_NAME
     , PRIMARY_ADDRESS_STREET
     , PRIMARY_ADDRESS_CITY
     , PRIMARY_ADDRESS_STATE
     , PRIMARY_ADDRESS_POSTALCODE
     , PRIMARY_ADDRESS_COUNTRY
     , PHONE_MOBILE
     , PHONE_HOME
  from vwLEADS_List
 where 1 = 1
   and (          FIRST_NAME like N'%A.N.S%' escape '\'
       )
   and BUSINESS_TYPE_C in ('TT')
 order by NAME asc;

Business Type field is as follow (I did SQL fdrom database):

<?xml version="1.0" encoding="UTF-8"?><Values><Value>O</Value><Value>RT</Value><Value>TT</Value></Values>



Previous Previous
 
Next Next
ForumForumMainstream Foru...Mainstream Foru...General Discuss...General Discuss...Search by checkboxes not working - BUG?Search by checkboxes not working - BUG?